当前位置:首页> 学堂>指标>MACD >正文

不断修改优化的MACD选股公式:超强“MACD看透主力”,让你一眼看穿主力动向!附指标公式源码

2020年04月07日 16:10:14 来源: 财富动力网综合

MACD指标在股市里面是一个比较常用的技术指标,在实践中,MACD指标的背离一般出现在强势行情中比较可靠,研究MACD的背离对我们买卖个股有很大的帮助,股价在高价位时,通常只要出现一次背离的形态即可确认股价即将反转,而股价在低位时,一般要反复出现几次背离后才能确认。因此,MACD指标的顶背离研判的准确性要高于底背离,这点投资者要加以留意。当然,笔者也要告诉你MACD指标背离的实用,一定要结合当时市场的成交量、价格以及其他一些指标,这样会更加准确。

 

当两条数值位于零轴下方,说明大势属于空头。相反,如果两条数值位于零轴上方,说明大势属于多头。

DIFF、DEA均为正,DIFF向上突破DEA,买入信号仅作参考;DIFF、DEA均为负,DIFF向下跌破DEA,卖出信号仅作参考;

分析MACD柱状线,由红变绿(正变负),卖出信号仅作参考;由绿变红,买入信号仅作参考。

DEA线:DIFF线的M日指数平滑移动平均线

DIF线:收盘价短期、长期指数平滑移动平均线间的差。

MACD有两个变量DIF与DEA,其中DIF是短期均线与长期均线之间的差值。学过均线应该知道,短期穿长期均线叫做黄金交叉,相反叫做死亡交叉。

MACD的意义和双移动平均线基本相同,但阅读起来更方便。当MACD从负数转向正数,是买的信号。当MACD从正数转向负数,是卖的信号。当MACD以大角度变化,表示快的移动平均线和慢的移动平均线的差距非常迅速的拉开,代表了一个市场大趋势的转变。

 

使用MACD指标在股市中所应当遵循以下原则:

当DIF和DEA处于0轴以上时,属于多头市场,DIF线自下而上穿越DEA线时是买入信号。DIF线自上而下穿越DEA线时,如果两线值还处于0轴以上运行,仅仅只能视为一次短暂的回落,而不能确定趋势转折,此时是否卖出还需要借助其他指标来综合判断 ;

 

2. 当DIF和DEA处于0轴以下时,属于空头市场。DIF线自上向下穿越DEA线时是卖出信号,DIF线自下而上穿越DEA线时,如果两线值还处于0轴以下运行,仅仅只能视为一次短暂的反弹,而不能确定趋势转折,此时是否买入还需要借助其他指标来综合判断;

 

3. 柱状线收缩和放大。一般的说,柱状线的持续收缩表明趋势运行的强度正在逐渐减弱,当柱状线颜色发生改变时,趋势确定转折 ;

 

4. MMACD指标也强调形态和背离现象。当形态上MACD指标的DIF线与MACD线形成高位看跌形态,应当保持警惕;而当形态上MACD指标DIF线与MACD线形成低位看涨形态时,应考虑进行买入;

MACD看趋势

经常在说要和趋势为伍,但往往是不清楚趋势是什么,或者根本不懂如何辨别趋势,结果导致只是下跌途中的反弹当成反转,还以为是多头行情来了,这样的判断难免有误,造成亏损。判断是多头行情还是空头行情最简单的方法是利用MACD。MACD中的DIF线可判断行情属于空头行情还是多头行情,当Dif在零轴上的时候为多头行情,当DIF小与零轴时为空头行情。

A类行情:DIF>0 同时MACD>0;

B类行情:DIF>0 同时MACD<0;

C类行情:DIF<0 同时MACD<0;

D类行情:DIF<0 同时MACD>0;

A类行情的参与性最高,完全处于牛市行情,如果看中中期行情,B好于C,如果短期行情好于B,中线投资可放弃C,D行情。在多头行情中,DIF,DEA,MACD都在零轴上表示强势多头,当DIF,DEA,MACD都在零轴小为弱势;

超强:DIF>DEA>0

次强:DIF﹣DEA>0(MACD>0)

弱势:DIF﹣DEA<0(MACD<0)

超弱:DIF

 

再来看一只牛股的走势

 

再来看一只熊股

 

看出什么规律来没?

再来看看大盘

 

规律:

A类行情后一定是B类行情;

B类行情后会有两个方向,继续A类,或者转变成C类;转化成A类重点一定是成交量,如果未出现放量,变成C类的概率很大;

C类行情后一定是D类行情,只有一种情况除外,就是DIFF已经位于零轴附近,这是可能会突然变成A类,这类行情的参与度与准确度极高,不过通常都是D类行情;

D类行情后有两个方向,一个是继续C类,一个是转变成A类,能否转变成A类的标准也一定是成交量的配合;

A类行情参与性最高,完全处于牛市行情;

B类行情有一定参与价值,但是有一定的风险;

C类行情处于空头行情,但是风险极高,在C类行情的结束的时候,有一定的参与性,C类会转化为D类;

D类行情和C类相比较,D类的操作难度偏大,因为C类过后是一定是D类行情,但是D类行情结束后,情况不一定,D类结束有可能会转化为A类,也有可能是C类(反复),对于短线投资来讲,完全关注A类,或C类就可以了。

如果看中中期行情,B好于C,如果短期行情好于B,中线投资可放弃C,D行情。

超强“MACD看透主力”:

指标用法:出现第一根黄中有红的柱子时就要关注了,第二天再根据情况择机介入。

 

 

 

 

 

 

 

超强MACD看透主力更新版公式指标公式源码:

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

SHORT:=12;LONG:=26;MID:=9;

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;

DEA:EMA(DIF,MID)COLORFF9900 ;

MACD:=(DIF-DEA)*2;

STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;

吸:=XLPL.NOTEXT吸;

拉:=XLPL.NOTEXT拉;

派:=XLPL.NOTEXT派;

落:=XLPL.NOTEXT落;

STICKLINE(吸,0,MACD,1,0),COLORLIRED;

STICKLINE(拉,0,MACD,1,0),COLORRED;

STICKLINE(派,0,MACD,1,0),COLORGREEN;

STICKLINE(落,0,MACD,1,0),COLORWHITE;

入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(DIF

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;

DRAWICON(二次金叉,DEA*0.9,1) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;

DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

公式代码复制过来难免造成部分格式错误,如果不能成功导入,可以找我领取源码!想了解更多目前A股阶段的操作技巧及公式代码,可关注公众号越声攻略(yslc688),更多后市操作及股票技术分析方法等你来学习,干货源源不断!

MACD之最佳卖点

1、 MACD最佳卖点:MACD柱状线与股价顶背离—股价回落时卖出

2010年2月至4月,中航地产000043的MACD和股价形成顶背离形态。这说明多方力量有变弱趋势。待空方力量复苏,股价将见顶下跌。

4月9日,股价已经和MACD柱线连续多次背离。此时k线图上出现一个变形的黄昏之星组合。投资者已经可以确定要卖出部分股票,继续观望。

4月13日,股价反弹没有仅需创新高就继续下跌,并且很快跌破前次回调低点,下跌趋势形成,清仓!

 

卖点精讲:

(1)MACD柱线与股价顶背离是看跌卖出信号。当两者连续三次背离时,背离形态已经完成。此时投资者可以先卖出部分股票。等到股价见顶下跌、跌破前次回调低点时,说明下跌趋势已经形成,投资者应该将手中剩余的股票卖出。

(2)MACD柱线和股价顶背离时,往往DEA线还在上涨过程中,只是其上涨的速度越来越慢。也就是说MACD柱线顶背离时所发出的卖出信号要比DEA线的信号更早。按照这个形态操作,投资者可以有效回避下跌行情开始后再卖出股票造成的损失。当然,投资者也需要承担踏空后市行情带来的风险。

(3)如果在MACD柱线和股价顶背离的同时成交量持续萎缩,是多方后续力量不足的表现。这样的情况下该形态的看跌信号更加可靠。

2、MACD最佳卖点:MACD柱状线由红变绿时—变绿时卖出

2010年4月29日,商业城600306的MACD由红转绿。表示空方开始主导行情,是看跌卖出信号。此时投资者可以先卖出部分股票,轻仓观望。

随后几个交易日,虽有小幅反弹,但MACD绿色柱线并没有明显变短。5月7日,股价跳空下跌,MACD绿色柱线再次边长。这样的形态表示空方已经巩固了对行情的主导地位,此时请赶紧清仓!

 

卖点精讲:

(1)MACD柱线由红翻绿的同时,如果成交量逐渐萎缩,则是对多方力量不足的验证。这种情况下该形态的看跌信号就更加可靠。

(2)MACD柱线翻绿之前在0轴上方持续时间越长,未来股价下跌的空间也就越大。

(3)如果MACD指标在0轴上方出现了与股价的顶背离形态后再翻绿,则该形态的看跌信号更加强烈。这样的情况下投资者应该尽快清空手中的股票,不必再等待绿色柱线逐渐变长。

3、MACD最佳卖点:DIFF线和DEA线拒绝金叉—DIFF线再次回落时卖

2010年5月7日,*ST新梅600732的DIFF和DEA形成了拒绝金叉的形态。这个形态说明空方力量仍在主导行情。之前的小幅反弹难以改变股价的长期下跌趋势。未来股价还将在空方的打压下继续下跌。当DIFF线重新开始回落时,清仓!

卖点精讲:

(1)MACD指标拒绝金叉的另一个形态是MACD柱线一开始是位于0轴下方的绿色柱线。随着股价反弹,绿色柱线逐渐变短。这组绿色柱线的长度缩短到极限后并没有翻红,而是再次变长。在实战中投资者可以用这两个同时出现的形态对照判断行情。

(2)如果DIFF先逐渐向DEA线靠拢的同时成交量逐渐萎缩,是多方后续力量不足的信号。在这种情况下,该形态的看跌信号会更加可靠。

(3)DIFF线和DEA线拒绝金叉的形态只有出现在下跌行情中才是有效的看跌信号。如果同样的形态出现在上涨行情中,表示多方暂时不能冲破空方防线,可能要积攒力量后再次发力。短期内股价可能会小幅回调,但长期上涨的行情难以改变。

(以上内容仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

声明:本内容由越声攻略提供,不代表投资快报认可其投资观点

【免责声明】本文仅代表作者本人观点,与财富动力网无关。财富动力网站对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证。请读者仅作参考,并请自行承担全部责任。

0条评论

网站导航
股票问答